题目背景
农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。
题目描述
约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。
你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000
输入输出格式
输入格式:
第一行: 农场的个数,N(3<=N<=100)。
第二行..结尾: 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。
输出格式:
只有一个输出,其中包含连接到每个农场的光纤的最小长度。
输入输出样例
输入样例#1: 复制
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
输出样例#1: 复制
28
说明
题目翻译来自NOCOW。
USACO Training Section 3.1
code:
#include<cstdio>
#include<algorithm>
using namespace std;
int n,cnt,sum,ans;
int fa[105];
struct edg{
int from,to,dis;
}edge[10005];
bool cmp(edg x,edg y){
return x.dis<y.dis;
}
int find(int x) //查找根节点
{
if(fa[x]==x) return x;
return fa[x]=find(fa[x]);
}
void join(int a,int b){
int x=find(a);
int y=find(b);
if(x!=y) fa[x]=y;
}
int main(){
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++){
int x;
scanf("%d",&x);
if(i!=j){
cnt++;
edge[cnt].dis=x;
edge[cnt].from=i,edge[cnt].to=j;
}
}
for(int i=1;i<=n;i++) fa[i]=i;
sort(edge+1,edge+cnt+1,cmp);
for(int i=1;i<=cnt;i++){
if(find(edge[i].from)!=find(edge[i].to)){
join(edge[i].from,edge[i].to);
sum+=edge[i].dis;
ans++;
}
if(ans==n-1) break;
}
printf("%d",sum);
return 0;
}
手机扫一扫
移动阅读更方便
你可能感兴趣的文章